Updating extensions for Firefox 2.0

It would appear that plenty of Firefox extension developers haven't got around to fixing their extensions to work with Firefox 2. In many cases these extensions don't work due to the maxVersion in the install.rdf file inside the xpi being set to only allow extensions to work with Firefox 1.5

I published some instructions for updating your extensions to work for 1.5 when that was launched so I though I'd update those instructions for Firefox 2 in case it's useful to one or two people.

Increasing maxVersion to allow extensions to work in Firefox 2.0

  1. Download to your desktop the extension you wish to get working
  2. Rename the .xpi file to .zip
  3. Open the zip file
  4. Either unpack the install.rdf file or open it for editing within your zip application if that is supported.
  5. Change the maxVersion to 2.*
  6. Repack the zip file or update the zip if you are editing within your archive app (should happen automatically - double check the file has been updated)
  7. Rename the .zip file to .xpi
  8. Test the extension. To install drag the xpi file onto an open window.

In due course the developers will no doubt release new version in which case these temporary hacked versions will be overwritten by the automated update process. However if the developer doesn't use this method you will need to manually check their sites for updates.

Feel free to drop a comment linking your favorite extensions that you have fixed to work in Firefox 2.0.

Update: AlastairC mentions in the comments below, the possibility of using the local install extension to be able to override the maxVersion on a per plugin basis. Sounds well worth checking out.

NB: I am aware that there is a way to bypass maxVersion checks on extensions using the nightly tester tools, but I personally would avoid this and prefer to fix each extension individually as this gives more control.