Firefox sees Charles Proxy CA certificate as expired

Update: This is no longer relevant the issue has been fixed with a Charles update.

Using current versions of Firefox with Charles Proxy you might run into a problem where Firefox see Charles' own CA certificate as expired when you try to install it.

After talking to some colleagues at Mozilla the cause is due to the way that Firefox validates certs. The more recent versions of Firefox only allow certs with start dates after the unix epoch (1st January 1970). As the Charles CA cert has a start year of 1899 it's seen as expired when you try to import it.

The easiest way to workaround it is to generate your own CA certificate and use that instead.

I've already filed a bug report with the author of Charles and will update this post with any updates in due course.